Nullpointerexception on first start

Free for all.

Nullpointerexception on first start

Postby platzebo » 12 Apr 2012 12:36

Hello,

i installed loadUI 2.0.0 on my WinXP(32) but I'm not able to start loadUI.
I'm getting the following error

<jnlp spec="1.0+" codebase="file:." href="loadUI.jnlp">
<information>
<title>loadUI</title>
<vendor>eviware</vendor>
<homepage href="http://www.loadui.org/"/>
<description>loadUI</description>
<offline-allowed/>
</information>
<resources>
<j2se version="1.7" java-vm-args="-Xms256m -Xmx768m -XX:MaxPermSize=128m -Dsun.java2d.noddraw=true"/>
<extension name="JavaFX Runtime" href="http://dl.javafx.com/1.3/javafx-rt.jnlp"/>
<jar href="lib/loadui-launcher.jar" main="true"/>
<jar href="lib/org.apache.felix.main.jar"/>
<jar href="lib/commons-cli.jar"/>
<jar href="lib/bndlib.jar"/>
</resources>
<security>
<all-permissions/>
</security>
<application-desc main-class="com.eviware.loadui.launcher.LoadUILauncher"/>
<update check="timeout" policy="always"/>
</jnlp>

java.lang.NullPointerException
at com.sun.javaws.security.SigningInfo.overlapSigners(Unknown Source)
at com.sun.javaws.security.SigningInfo.getCertificates(Unknown Source)
at com.sun.javaws.security.JNLPSignedResourcesHelper.checkSignedResourcesHelper(Unknown Source)
at com.sun.javaws.security.JNLPSignedResourcesHelper.checkSignedResources(Unknown Source)
at com.sun.javaws.Launcher.prepareResources(Unknown Source)
at com.sun.javaws.Launcher.prepareAllResources(Unknown Source)
at com.sun.javaws.Launcher.prepareToLaunch(Unknown Source)
at com.sun.javaws.Launcher.prepareToLaunch(Unknown Source)
at com.sun.javaws.Launcher.launch(Unknown Source)
at com.sun.javaws.Main.launchApp(Unknown Source)
at com.sun.javaws.Main.continueInSecureThread(Unknown Source)
at com.sun.javaws.Main$1.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)

What have I done wrong?

thx mike
platzebo
User
 
Posts: 2
Joined: 12 Apr 2012 12:31

Re: Nullpointerexception on first start

Postby bendaluz » 12 Apr 2012 14:30

I have the same on Windows 7 (64 bit)
bendaluz
User
 
Posts: 2
Joined: 12 Apr 2012 14:24

Re: Nullpointerexception on first start

Postby SmartBear Support » 12 Apr 2012 15:12

Hi,

Try starting loadUI again. If that doesn't work, please try the steps here. How many Java versions do you have installed?


Regards

Henrik
SmartBear Software
SmartBear Support
Administrator
Administrator
 
Posts: 8788
Joined: 16 Feb 2009 10:53

Re: Nullpointerexception on first start

Postby bendaluz » 12 Apr 2012 16:59

I have eventually managed to get it running by following the steps on the link you provided. However the following happened (which might help someone else)

I removed the cached files and deleted all the Trusted Certificates from the Java control panel and reinstalled loadUI
When I ran loadUI again, I no longer got the NullPointerException and the splash screen appeared but after 10 seconds or so it disappeared and the process ended without any error

I then had to do the javaws -uninstall again and after that was able to run loadUI successfully

Thanks for the help :-)
bendaluz
User
 
Posts: 2
Joined: 12 Apr 2012 14:24

Re: Nullpointerexception on first start

Postby platzebo » 16 Apr 2012 14:21

Hy,

it's getting better :) - now - I'll get the splashscreen and the following error

Java Web Start 10.1.0.8
JRE-Version verwenden 1.7.0_03-b05 Java HotSpot(TM) Client VM
Benutzer-Home-Verzeichnis = C:\Benutzer\lrzwnes
----------------------------------------------------
c: Konsolenfenster löschen
f: Objekte in Finalisierungs-Queue finalisieren
g: Garbage Collect
h: Diese Hilfemeldung anzeigen
m: Speicherauslastung drucken
o: Logging auslösen
p: Proxykonfiguration neu laden
q: Konsole ausblenden
r: Policy-Konfiguration neu laden
s: System- und Deployment-Eigenschaften ausgeben
t: Threadliste ausgeben
v: Thread-Stack ausgeben
0-5: Trace-Ebene auf <n> setzen
----------------------------------------------------
Opening splash...
Detected from bootclasspath: C:\\Program Files\\SmartBear\\loadUI-2.0.0\\jre\\lib\deploy.jar
Launching loadUI Build: rc-15 2012-03-28_10-32-34
ERROR: Bundle com.eviware.loadui.cssbox-browser [36] Error starting file:/C:/Program%20Files/SmartBear/loadUI-2.0.0/bundle/loadui-cssbox-browser-2.0.0.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle com.eviware.loadui.cssbox-browser [36]: Unable to resolve 36.0: missing requirement [36.0] osgi.wiring.package; (osgi.wiring.package=org.antlr.runtime))
org.osgi.framework.BundleException: Unresolved constraint in bundle com.eviware.loadui.cssbox-browser [36]: Unable to resolve 36.0: missing requirement [36.0] osgi.wiring.package; (osgi.wiring.package=org.antlr.runtime)
at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3826)
at org.apache.felix.framework.Felix.startBundle(Felix.java:1868)
at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191)
at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:295)
at java.lang.Thread.run(Unknown Source)
ERROR: Bundle com.eviware.loadui.fx-interface [37] Error starting file:/C:/Program%20Files/SmartBear/loadUI-2.0.0/bundle/loadui-fx-interface-2.0.0.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle com.eviware.loadui.fx-interface [37]: Unable to resolve 37.0: missing requirement [37.0] osgi.wiring.package; (&(osgi.wiring.package=com.eviware.loadui.util.browser)(version>=2.0.0)(!(version>=3.0.0))) [caused by: Unable to resolve 36.0: missing requirement [36.0] osgi.wiring.package; (osgi.wiring.package=org.antlr.runtime)])
org.osgi.framework.BundleException: Unresolved constraint in bundle com.eviware.loadui.fx-interface [37]: Unable to resolve 37.0: missing requirement [37.0] osgi.wiring.package; (&(osgi.wiring.package=com.eviware.loadui.util.browser)(version>=2.0.0)(!(version>=3.0.0))) [caused by: Unable to resolve 36.0: missing requirement [36.0] osgi.wiring.package; (osgi.wiring.package=org.antlr.runtime)]
at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3826)
at org.apache.felix.framework.Felix.startBundle(Felix.java:1868)
at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191)
at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:295)
at java.lang.Thread.run(Unknown Source)
Configuring log4j from [C:\Program Files\SmartBear\loadUI-2.0.0\soapui-log4j.xml]
15:13:39,975 INFO [DefaultSoapUICore] initialized soapui-settings from [C:\Benutzer\lrzwnes\soapui-settings.xml]
15:13:40,147 WARN [SoapUIProGroovyScriptEngineFactory] Missing scripts folder [C:\Program Files\SmartBear\loadUI-2.0.0\scripts]
15:13:40,553 INFO [SchemaUtils] Added default schema from /com/eviware/soapui/resources/xsds/xop.xsd with targetNamespace http://www.w3.org/2004/08/xop/include
15:13:40,584 INFO [SchemaUtils] Added default schema from /com/eviware/soapui/resources/xsds/XMLSchema.xsd with targetNamespace http://www.w3.org/2001/XMLSchema
15:13:40,584 INFO [SchemaUtils] Added default schema from /com/eviware/soapui/resources/xsds/xml.xsd with targetNamespace http://www.w3.org/XML/1998/namespace
15:13:40,584 INFO [SchemaUtils] Added default schema from /com/eviware/soapui/resources/xsds/swaref.xsd with targetNamespace http://ws-i.org/profiles/basic/1.1/xsd
15:13:40,584 INFO [SchemaUtils] Added default schema from /com/eviware/soapui/resources/xsds/xmime200505.xsd with targetNamespace http://www.w3.org/2005/05/xmlmime
15:13:40,584 INFO [SchemaUtils] Added default schema from /com/eviware/soapui/resources/xsds/xmime200411.xsd with targetNamespace http://www.w3.org/2004/11/xmlmime
15:13:40,584 INFO [SchemaUtils] Added default schema from /com/eviware/soapui/resources/xsds/soapEnvelope.xsd with targetNamespace http://schemas.xmlsoap.org/soap/envelope/
15:13:40,584 INFO [SchemaUtils] Added default schema from /com/eviware/soapui/resources/xsds/soapEncoding.xsd with targetNamespace http://schemas.xmlsoap.org/soap/encoding/
15:13:40,584 INFO [SchemaUtils] Added default schema from /com/eviware/soapui/resources/xsds/soapEnvelope12.xsd with targetNamespace http://www.w3.org/2003/05/soap-envelope
15:13:40,600 INFO [SchemaUtils] Added default schema from /com/eviware/soapui/resources/xsds/soapEncoding12.xsd with targetNamespace http://www.w3.org/2003/05/soap-encoding
ShellTUI: No standard input...exiting.
log4j:WARN No appenders could be found for logger (org.springframework.osgi.extender.internal.activator.ContextLoaderListener).
log4j:WARN Please initialize the log4j system properly.
log4j:WARN See http://logging.apache.org/log4j/1.2/faq.html#noconfig for more info.
-> Framework started!
Apr 16, 2012 3:14:00 PM com.eviware.loadui.launcher.LauncherWatchdog run
Schwerwiegend: Bundle: com.eviware.loadui.cssbox-browser failed state: 2
Apr 16, 2012 3:14:00 PM com.eviware.loadui.launcher.LauncherWatchdog run
Schwerwiegend: Headers: {ALLUSERSPROFILE=C:\ProgramData, APPDATA=C:\Users\Administrator\AppData\Roaming, Bnd-LastModified=1332919804038, Build-Jdk=1.6.0_23, BUILD_ID=2012-03-28_09-27-52, BUILD_NUMBER=13, BUILD_TAG=hudson-loadui-2.0.0-rc-13, BUILD_URL=http://http://hudsontest.eviware.local:8080/hudson-2.1.2/job/loadui-2.0.0-rc/13/, Built-By=Administrator, Bundle-ClassPath=.,cssbox-3.4.jar,jStyleParser-1.5-cssboxdep.jar,annotations-2.0.0.jar,jsr305-2.0.0.jar, Bundle-Description=loadUI CSSBox Browser Component, Bundle-ManifestVersion=2, Bundle-Name=loadUI Browser, Bundle-SymbolicName=com.eviware.loadui.cssbox-browser, Bundle-Version=2.0.0, CommonProgramFiles=C:\Program Files\Common Files, CommonProgramW6432=C:\Program Files\Common Files, COMPUTERNAME=HUDSONTEST, ComSpec=C:\Windows\system32\cmd.exe, Created-By=Apache Maven Bundle Plugin, Embed-Dependency=*;scope=provided, Embedded-Artifacts=cssbox-3.4.jar;g="cssbox";a="cssbox";v="3.4",jStyleParser-1.5-cssboxdep.jar;g="cssbox";a="jStyleParser";v="1.5-cssboxdep",annotations-2.0.0.jar;g="com.google.code.findbugs";a="annotations";v="2.0.0",jsr305-2.0.0.jar;g="com.google.code.findbugs";a="jsr305";v="2.0.0", EXECUTOR_NUMBER=2, Export-Package=com.eviware.loadui.util.browser;uses:="org.slf4j,com.gargoylesoftware.htmlunit,com.gargoylesoftware.htmlunit.html,org.w3c.dom,com.google.common.base,com.google.common.collect,org.xml.sax,javax.swing";version="2.0.0", FP_NO_HOST_CHECK=NO, HUDSON_HOME=E:\hudson, HUDSON_SERVER_COOKIE=d4229163fea114593be547aa0f386798, HUDSON_URL=http://http://hudsontest.eviware.local:8080/hudson-2.1.2/, Ignore-Package=org.hamcrest.core,junit.framework,org.hamcrest,org.junit, Import-Package=com.gargoylesoftware.htmlunit;version="[2.6,3)",com.gargoylesoftware.htmlunit.html;version="[2.6,3)",com.google.common.base;version="[11.0,12)",com.google.common.collect;version="[11.0,12)",javax.imageio,javax.swing,javax.swing.event,javax.swing.table,javax.swing.tree,org.antlr.runtime,org.antlr.runtime.tree,org.apache.xerces.parsers;version="[2.9,3)",org.apache.xerces.xni.parser;version="[2.9,3)",org.cyberneko.html;version="[1.9,2)",org.slf4j;version="[1.6,2)",org.w3c.dom;version=0,org.w3c.dom.traversal;version=0,org.xml.sax;version=0, INSTALL4J_HOME=E:\dev\install4j\, JAVA_HOME=C:\Program Files\Java\jdk1.6.0_23, JAVAFX_HOME=C:\java\javafx-sdk1.3, JOB_NAME=loadui-2.0.0-rc, JOB_URL=http://http://hudsontest.eviware.local:8080/hudson-2.1.2/job/loadui-2.0.0-rc/, LOCALAPPDATA=C:\Users\Administrator\AppData\Local, M2_HOME=c:\java\apache-maven-2.2.1, Manifest-Version=1.0, MAVEN_HOME=C:\java\maven-1.0.2, MAVEN_OPTS=-Dloadui.build.date=2012-03-28_09-27-52 -Dloadui.build.number=rc-13 -Ddevenv.install4jc="e:\\dev\\install4j\\bin\\install4jc.exe" -Dmaven.jnlp.signjar.store=e:\\dev\\eviware-cert\\eviware.key -Dmaven.jnlp.signjar.storepass=soa4ever -Dmaven.jnlp.signjar.alias=eviware -Dmaven.install4j.cert=e:\\dev\\eviware-cert\\smartbear_certificate.pfx -Dmaven.install4j.cert.pass="1999aqa" -Dmaven.install4j.signtool=e:\\dev\\eviware-cert\\signtool.exe -Djide.company="eviware software ab" -Djide.product="TBA" -Djide.license="MdOi52WCigxz8qr9p2W9ZPolKitJKKg1" -Dpublish.dir=publish -Dmaven.test.skip=true -Dmaven.repository.path=e:\\maven2\\repository, NODE_LABELS=master, NUMBER_OF_PROCESSORS=2, OS=Windows_NT, Path=C:\java\javafx-sdk1.3\bin;C:\java\javafx-sdk1.3\emulator\bin;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Program Files\Java\jdk1.6.0_23\bin;C:\java\maven-1.0.2\bin;C:\Program Files\SlikSvn\bin\, PATHEXT=.COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH;.MSC, PROCESSOR_ARCHITECTURE=AMD64, PROCESSOR_IDENTIFIER=Intel64 Family 6 Model 26 Stepping 5, GenuineIntel, PROCESSOR_LEVEL=6, PROCESSOR_REVISION=1a05, ProgramData=C:\ProgramData, ProgramFiles=C:\Program Files, ProgramW6432=C:\Program Files, PSModulePath=C:\Windows\system32\WindowsPowerShell\v1.0\Modules\, PUBLIC=C:\Users\Public, SVN_REVISION=8184, SVN_URL=svn://svn.eviware.com/loadui/branches/loadui-2.0.0/loadui-project, SystemDrive=C:, SystemRoot=C:\Windows, TEMP=C:\Users\ADMINI~1\AppData\Local\Temp, TMP=C:\Users\ADMINI~1\AppData\Local\Temp, Tool=Bnd-1.50.0, USERDOMAIN=HUDSONTEST, USERNAME=Administrator, USERPROFILE=C:\Users\Administrator, WORKSPACE=E:\hudson\jobs\loadui-2.0.0-rc\workspace}
org.osgi.framework.BundleException: Unresolved constraint in bundle com.eviware.loadui.cssbox-browser [36]: Unable to resolve 36.0: missing requirement [36.0] osgi.wiring.package; (osgi.wiring.package=org.antlr.runtime)
at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3826)
at org.apache.felix.framework.Felix.startBundle(Felix.java:1868)
at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:944)
at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:931)
at com.eviware.loadui.launcher.LauncherWatchdog.run(LauncherWatchdog.java:62)
at java.lang.Thread.run(Unknown Source)

I'm using jre7 (1.7.0_03). On the second start - I'll get the NullPointerException again
platzebo
User
 
Posts: 2
Joined: 12 Apr 2012 12:31

Re: Nullpointerexception on first start

Postby Graham1 » 27 Nov 2012 07:47

Just installed 1.9-M01. I no longer see the NullPointerExceptions.
However, the other problem still exists. In my case this is the
"RelationshipRecord[nnn] not in use" error that occurs when I issue
concurrent Cypher DELETEs across a number of nodes that share
relationships. The test is designed to produce deadlock exceptions so that
I can test a retry strategy. Once this error occurs, any query that would
traverse that relationship (e.g. start r = rel(*) return r) fails with the
same error until I restart the neo4j server. This error does not occur if
I set cache_type=none.
Graham1
User
 
Posts: 1
Joined: 27 Nov 2012 07:35


Return to LoadUI