Getting unrecognized character on webservice response

This is community board for the SoapUI Community. Here the members can exchange experiences and help each other improve their soapUI testing.

Getting unrecognized character on webservice response

Postby yey2000 » 23 Oct 2009 19:42

I have two computers, for each of them, I am using SOAPUI 2.5.1 and 3.0.1 to test a web service. On both machines, I imported the WSDL and created test cases.

One one machine, I was able to test the web service succesfully see the response coming back correctly in both XML and Raw tab.

On the other machine, for the same web service, the response message I get has lots of unregonized characters.

--- In the Raw tab,  first part of the message is ok, but the rest is unrecognizable

HTTP/1.1 200 OK
Date: Fri, 23 Oct 2009 17:50:26 GMT
.....

¼S]o‚0ý+
f{€Â’E£X£“ù‘à–ìɸ[¡¦-2÷ëWÅ=墳çžsîímëN¾2†N dÊó±áX¶� y”æñØxÝ-Ì�1!®¿™nMoý6ôò0~¤e¹þâc#Qê8ÄX† dTZ:-9=Z\Äø²ÁP ±qå6ãÑù*\Ђ)â.‹nH“ñAè]ܦ*–TB7JÞy!P( J
©ˆPÈ ¡œ+

--- In the XML tab, everything is unrecognized

�S]o�0�+
f{�’E�X�������[��-2��W�=墳�s��m�N�2�N d���X�� y����x�-́1!���nMo�6��0~�e���c#Q�8�X� dTZ:-9=Z\���P �q�6���*\Ђ)�.�nH��A�]ܦ*�TB7J�y!P( J
��P� ��+

Any idea how to fix this, it looks like a machine dependent issue, or is there any SOAPUI preference that will parse the response message correctly.

Thanks
Yi
yey2000
User
 
Posts: 2
Joined: 23 Oct 2009 18:29

Re: Getting unrecognized character on webservice response

Postby SmartBear Support » 25 Oct 2009 23:07

Hi!

it looks like the message is either compressed or encrypted (or both), can you check the encryption related settings in the global http preferences?

If that doesn't help, can you show all http headers returned with the response as shown in the RAW tab?

regards!

/Ole
eviware.com
SmartBear Support
Administrator
Administrator
 
Posts: 8587
Joined: 16 Feb 2009 10:53

Re: Getting unrecognized character on webservice response

Postby ufohunter » 12 Jan 2010 03:08

Hi,

Did you ever get this resolved? I'm getting the same problem but only on a https WS. The same WS over http returns areadable response. I assume it is encrypted, but can't figure out how to get around it.

Would appreciate any info on this.

Thanks.
ufohunter
User
 
Posts: 2
Joined: 12 Jan 2010 03:05

Re: Getting unrecognized character on webservice response

Postby Dunderklumpen » 24 Mar 2010 04:53

I was a about to post a reply stating that I was having the exact same problem, but we have solved our problem, so perhaps this is solution for you also.

My situation was the same: working on machine 1 (xml response), not working on machine 2 (strange characters in response).

In this case the web service being called was provided by Siebel 8.1 (although that may not be important).

After checking the HTTP headers in the "raw" tab of the XML request and response, I noticed the following in the header of the non-working request.

Code: Select all
Accept-Encoding: gzip,deflate


and also this in the HTTP header of the response

Code: Select all
content-encoding: deflate


The request header and response header for the working request did not have these lines.

You can turn this off (in SOAP-UI 3.0.1) by going to HTTP Settings in the Preferences dialog (File >Preferences > HTTP Settings tab) and turning off "Accept compressed responses from host".

Hope this helps
Last edited by Dunderklumpen on 24 Mar 2010 04:55, edited 1 time in total.
Dunderklumpen
User
 
Posts: 1
Joined: 24 Mar 2010 04:22

Re: Getting unrecognized character on webservice response

Postby rb » 06 May 2010 18:17

thanks dunderklumpen, that worked for me!
rb
User
 
Posts: 2
Joined: 06 May 2010 18:10


Return to SoapUI Community Board